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When to Use a Template

Many of the tasks we perform in Word are repeated over and over
Writing a letter
Sending a Fax
Preparing an invoice
Writing a report
Preparing an Expense Report

Any time you find yourself re-performing a Word or Excel task, consider
the opportunity to create a reusable template

If you are interested in maintaining corporate standards for look, feel
and content, templates are the way to go.

1. Word — Using Form Fields (cont)

4 Form Fields using the Forms Toolbar

= To use Form Fields, add the Forms Toolbar by selecting Toolbars from
the View Menu




1. Word - Using Form Fields (cont)

4 The Forms Toolbar contains the following buttons:
Text Form Field — for use in entering any text

Check Box Form Field - insert a check box next to each item in a group
of choices that are not mutually exclusive

Drop-Down Form Field — select an entry from a list of valid values
Form Field Options — provides options for the Drop-Down Form Field.

Form Field Shading - appears on the screen so users can quickly
identify the fields they need to respond to. This shading does not print.

Reset Form Fields - If the form contained data, Microsoft \Word
preserves the data when you protect the form again. You can clear the
data by clicking Reset Form Fields.

Protect Form - To make form fields active so that users can enter
information but cannot accidentally change a form as they fill it in, the
form must be locked, or protected.

1. Word - Using Form Fields (cont)

Let’s try an example, entering
each type of form field and
setting it up for automation.

Let’s take our fax template

and automate it.

We’ll enter each type of form
field, turn on shading, and
Protect the form to automate
it.

Once we save the template, it
will be ready for reuse from
the File, New menu option.
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2. Word - Advanced Field Codes

@ Field Codes using the Insert, Fields menu option

= Word also comes with over 70 additional form fields that can be added
to your document from the Insert, Fields menu option

Examples include:
® Entering page numbers and file names in your footer
¢ Entering a date and time stamp in your letterhead

For information on each of these fields, hit the F1 button and enter the
field name in the search for box

2. Word - Advanced Field Codes

@ Field Codes using the Insert, Fields menu option

= My personal favorites are the Ask, Ref and Fill-in fields

These fields allow you to create customized dialog boxes that prompt
the user for data entry and then populate the document as required.

| use the Ask and Ref fields whenever the required data is to appear in
the document multiple times.

| use the Fill-In field whenever the required data is only required once in
the document.




2. Word - Advanced Field Codes

4 Field Codes using the Insert, Fields
menu option

= Let's try an example st ;mw T T |
e e D] rYTE e

Open a blank Word document e V{J%ﬁ PRPClA

From the Insert menu, select Field
and click on Ask

In the Prompt box, enter “Enter the
client name then click OK”

In the Bookmark Name, enter
“ClientName”, with no spaces

Click OK N )

When the dialog box appears, type §& e
“ABC Co. Ltd.” and click OK b

Hit the Enter key to move to the
next line in the document

2. Word - Advanced Field Codes

4 Field Codes using the Insert, Fields
menu option

. . Please choose  field Field properties Field options
= Now, we will add a REF field Cateqories: Baokmark name:

(A ] W [ humber separator:
Select REF, in the Insert, Field ek names: ) [F [ R s
H NoteRef Iz numbers
dlalog 0]0)'¢ HumChars ] Hyperlink to paragraph

HumP ages
Numiords [ Paragraph # from marked paragraph

In the Bookmark name box, select
ClientName - if the Bookmark [ Reltive pasiscn of parasraph
Name doesn’t appear, click the 3 ]| ] # of paragraph in elatve context
Field Codes button and enter — [0 uperess a ron-delmter chars
“ClientName” after REF in the Field gtﬂ L F(”‘) o1 Dlpsremasn # ot

Codes box e

Insert the text marked by 5 hookmark

Clle OK [ Preserys Formatting during updates
You should now see the result

Use the REF field wherever you

want the client name to appear in

your template




2. Word - Advanced Field Codes

Py

# Field Codes using the Insert,
Fields menu option

Flease chonse a field Field properties Field options
Categories: Prompt;

NOW, we will add a Fill-in Field Jcay [v] | [T G | [ Dsfauktresponse to

promp:
g ] . Eield names: i

Select Fill-in, in the Insert, Field [EEGi—_

dialog box Dactrapety

Docvariable

[ Brampk befare merging bookmark. text

In the Prompt box, type “Enter [N
the Client Name and then click

| GoToButton

O K” | GreetingLine

Hyperlink

¥ |
. | IncludePicture v
Click OK Description:
Prompt the wser For text ta insert in the document
Preserye formatting during updates

When dialog box appears, type

“ABC Co. Ltd.” and click OK

2. Word - Advanced Field Codes

Of course, being a MicroSoft product, the use of advanced field codes in
Word has its challenges. One challenge is to activate the field codes.

Dialog boxes can be activated by hitting the F9 key. However, this only
works if you highlight the Ask field code, which is hidden in your

document. If you have multiple dialog boxes, it can even be a greater
challenge.

Here is my solution:

Create a macro in the Word template, that highlights the entire document
and presses the F9 key. This will activate all dialog boxes in the
document.

Create a button on your form, called Activate Form, with a hyperlink to the
macro.

This may sound complicated, but I'll demonstrate that it is not too difficult.




2. Word - Advanced Field Codes

# From the Tools menu, select Macro, Record New Macro.
= Name the macro, i.e. Automate Form.

= |n the Store Macro In dropdown box, select the name of the
“All documents (normal.dot).

Under “Assign Macro To”, click on Toolbars. The Forms
toolbar should display on the left, and the Automate Form
macro should appear on the right. Drag the Automate
Form macro to the Forms Toolbar on your desktop. Click
Close. The Macro toolbar will display on screen.

On the Edit menu, click Select All. Press F9. Click OK for
any dialog boxes that appear.

Press CTRL+HOME so that the text is no longer selected.
Click the Stop Recording button on the Macro toolbar.

3. Word — Mail Merge

Another time saving feature in Word is
mail merge.

Mail merge should be considered for any - |
repetitive activity where data from a table Address Form

is merged with a form. The form could Database Letter

be a letter, an envelope or any other ' e

document.

-
Mail merge will merge data from a Word .
Table or an Excel Spreadsheet. Mail Merge

Let’s use an example where a form letter
is to be merged with a mailing list.

Letters




3. Word — Mail Merge

¢ Example:

We have a form letter
to merge with the
database.

We have an address
database in Word.

Each column has a
unigue name.

Open the form letter
and from the Tools
menu, select Letters
and Mailings, Mail
Merge.

3. Word — Mail Merge

4 Example:

= In the dialog box on the right,
select Letters. At the bottom,
click to the Next Step.

Select, Use the Current
Document. Click Next Step.

In Select Recipients, select
Use an Existing List. Click the
Browse button to locate your
address database file. Click
OK. Click to Next Step.

Position your cursor where you
want the address located.
Click on Address Block on the
left. Configure the Address
Block as required. Click on
Match Fields button to link the
address database to the
merge.




3. Word — Mail Merge

< Example:

= Next, highlight where you
want the greetings to go
and click on Greetings Line
on the right. Select the
options that fit best. Click
OK. Click Next Step.

You can now preview your
merged letter. If changes
are required, go back to
the appropriate step and
make the correction.

If finished, click Next:
Complete the Merge. A
merged document file is
now created.

4. Excel — Data Validation

For many organizations, Excel is the tool of choice when it comes to
developing small databases or financial applications.

As with any End-User developed application, there is a high risk of data
quality problems.

Excel’s Validation feature provides a mechanism for reducing the risk of
data entry errors and speeding data entry.

It’s relatively simple to use!

So, how does it work?
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4,

Excel — Data Validation

Let’s use an Expense Report as an
example.

In this example, there are two
fields (name and account) that
must be validated.

First, we need a list of valid
values. A table of valid employee
names is located in the workbook.
For Validation to work, the table
must be in the Expense Report
worksheet. Copy the table and
paste it to cell V1.

In cell C7, click on the Data menu
and select Validation.

Excel — Data Validation

In the Allow box, select List. In the
Source box, click on the Arrow to
browse to the Employee Table.

Select cells W2:W7. This includes
all the employee names, plus a
blank record (hint: so you can
leave the field blank). Click on the f§
Arrow button, then Click OK.

Return to cell C7. You will now

see a drop down arrow in the righ
corner of cell C7. Click on the
arrow to see the employee list. :
Now only values from this list can
be entered.

The list must be maintained in the
template.
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4, Excel — Data Validation

Do the same for the Account field.
Create an account list in the
Expense Report template, off to
the side.

Highlight cells C11:C25.

Select Validation from the Data
menu. Select List from the Allow
box. In Source, navigate to the
account listing, highlighting all of
the accounts plus one blank row.

The Account field can now only be
populated from the drop down list.

The Account Listing must be
maintained in the template.

5. Excel/— Protecting Formulas

4 In our Expense Report example, there are a number of calculated fields.
These fields are not currently protected and could be inadvertently
overwritten. As a result, it is possible that totals are not accurate and
could even be deliberately manipulated.

¢ Excel allows you to protect cells that you do not want overwritten.




5. Excel— Protecting Formulas

# Protection is applied as follows:

First, highlight all cells that are
allowed to change.

From the Format menu, select
Cells, Protection and unclick the
Locked button. This un-protects
cells that are allowed to change.
The default status is Locked.

2| Expense report

Now, from the Tools menu, select
Protection, Protect Sheet. A
password can be applied or not.

Calculated cells are now protected.

6. Excel— Automating Data Entry

Once the spreadsheet is protected, we get an added benefit. If we hit the
TAB key, it navigates horizontally, then vertically, through only those
cells that are unprotected. This can greatly speed up the data entry
process.

Another way to automate date entry is the use of a Data Form. This is
ideal for situations where there are many fields in each data row.
Particularly if some fields are not to be used for data entry. A Data Form
can display up to 32 data entry fields.

In this case, the expense details are entered in cells B11:K25. The
headers are in row 10. So highlight B10:K25. On the Data menu, click
Form.

A data form now appears, with a field for each column. Note that the
Account field, while still validated, no longer has a drop down list. If you
enter an invalid account number, the record will not be accepted.
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7. Excel - Navigation Buttons

Py

# Navigating back and forth through multiple spreadsheets in a workbook
can be a pain, especially when the number of spreadsheets is large.

@ There are several built in methods of navigation:

= We can click on the worksheet tabs on the navigation bar at the bottom of
the screen.

= On the left of the navigation bar, there are four arrow buttons, which allow
you to move right or left through the sheets, or to the first or last sheet. As
well, you can also right mouse click on the arrows and a listing of all sheets
will appear. Click any of the sheets to go to it.

Sheet1

Sheet2

34
1 4 » »i\Sheet1 / Sheet2 / Sheet3 / Sheetd / Sheets / e

iDraw> e | Aoshapes> N\ W [0 O [ <l #3 [g] Lal | Sheetd
Sheets
Ready oreeery Sheet2 [/ Sheet3 f sheetd / sheets /

ipraw~ L | Autoshapes~ N\ [ O [ < 3 (8] (&l | & -
P Ready

7. Excel - Navigation Buttons

Another approach is to create navigation buttons on each
worksheet, that are linked to macros that quickly move
between worksheets.

Here’s an example:

= Open the Expense Report sheet. Select an Autoshape from
the Drawing Toolbar to create a Button. Enter “Go To Chart
of Accounts” in the Autoshape. Format to your preference.

From the Tools menu, select Macro, Record New Macro.
Assign a name, with no spaces (i.e.,ChartOfAccounts).
Select which workbook to include the macro in. The macro
can also be assigned a shortcut key. Click OK.

Now, navigate to the Chart of Accounts Sheet and press the
STOP button on the Macro Toolbar. Return to the Expense
Report.

Now, right mouse click on the Button, and select Assign
Macro. Click on the ChartOfAccounts macro and click OK.

Now, click on the Button and you will automatically be
transferred to the Chart of Accounts.

Perform the same steps to create a button to navigate from
the Chart of Accounts back to the Expense Report.




Excel — Lookup Tables

Another method for enhancing an Excel
template is with the use of Lookup Tables.

Lookup Tables are ideal for populating data
when there are relationships between data
elements.

Let’s use the Expense Report as our example.

In the Expense Report, the employee is asked to
identify their name, department, position, :
manager, SSN and Employee ID. These
relationships seldom change. Once we know
the employee name, we should be able to
populate all other data elements with a Lookup
Table.

Excel — Lookup Tables

Let’s start with the department field. Make C8
the active cell. In the formula bar, click on the
Formula button (fx). Enter “Vlookup” and click
Go. Select Vlookup and click OK.

In the Lookup Value, enter C7 (Employee
Name).

In the Table Array, click the arrow and highlight [§
the Employee Table in the other worksheet. The
Employee Name must be in the left most

column.

In the Column Index #, enter the column number &
for department (3" column from left).

Repeat the process for all remaining data fields.
Now, only the employee name need be entered.
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9. Excel — Conditional Formatting

As financial managers, we regularly perform financial analyses using
Excel. We may be looking for unusual entries or unusual variances.
The easier it is to see these variances, the more effective is the
spreadsheet.

Conditional Formatting is a means of highlighting certain cells based
upon a set of pre-conditions.

9. Excel — Conditional Formatting

4 Here’s an example:

= Open the example spreadsheet with three columns
of invoice information: Invoice #, Invoice Date and
Invoice Amount.

Table 1 is the data without conditional formatting.

In Table 2, we will apply conditional formatting to all
three columns.

For Invoice number, the starting invoice number was
222 and ending was 246.

For Date, all invoice dates should be in 2008.

All invoice amounts should be a positive amount.
We are interested in identifying any credit notes or
large unusual amounts (>$2,500).

Can you see any data problems in Table 17?




9. Excel — Conditional Formatting

4 Here’s an example:

To apply Conditional Formatting, first highlight the cells to apply the
formatting to.

From the Format menu, select Conditional Formatting. Multiple conditions
can be applied.

For the Invoice column, apply the condition that invoice numbers must be
between 221 and 247. Click on the Format button and pick a conditional
format (make it stand out!). Click OK.

For the date column, apply the condition that dates must be between
January 1, 2008 and December 31, 2008.

For the amount column, apply two conditions: that amounts less than $0
are highlighted and amounts greater than $2,500 are highlighted.

With conditional formatting applied, was it easier to identify the data
problems?

10. Word/Excel — Saving a Template

Whether Word or Excel, we can save our
document as a template.

Select Save As, from the File Menu

4 In the Save as type box, select Document [ —
Template (Word) or Template (Excel). - ==

Office should automatically open your
personal template folder

Select the appropriate folder and click on
the Save button.

You now have templates to support your
administrative productivity.
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10. Word/Excel — Saving a Template

To use the template, select New from the File Menu
A New Document list will come up on the left side of the screen

Select Templates, On My Computer

10.Word/Excel — Saving a Template

4 Navigate to the document template you want in the Template Folder list
@ Select the document and click OK

General | AS Templates Billng & ... Envelopes ... Global work ... IRM
| KPMG Carres ... KPMG Prasen ... Qualley Per ... Corresponda ... Working pap ...

g o9 @ 7 pooc

Audit Fax Inc.dot  [ERQUGHEEN  Fax MSLP.dot
Canadian ...

g 82 83 3
Fax.dot  Flyshest.dot  Full Report Gord's
Templat, .. Faxz,dot

g 9 g g

Gords  Gord'sletter  Letter.dot  Letterhsad o
Flysheet.dot  Template.dat and signat...

o

Create New

[ 1 [ 1 & I [ I [w] @Document O Tempiste




Resources

@ http://office.microsoft.com/en-
us/templates/default.aspx

¢ http://search.techrepublic.com.com/
search/microsoft+office+and+templ
ate.html

Don't let the
Recession Worry
You




